Affiche les résultats de 1 à 5 sur 5

Sujet : [Réglé] Problème d'installation de kmldonkey sur SuSE 10.1

  1. #1
    Bonjour,

    Je suis en train d'essayer d'installer kmldonkey sur la SuSE 10.1 (kmldonkey était dispo sur le DVD de la 10.0....???) avec un paquet récupéré de chez Packman (http://packman.links2linux.org).

    En root, je tape et obtiens l'eereur suivante:

    noestrium:/tmp # rpm -i kmldonkey-0.10.1-1.pm.2.i586.rpm
    warning: kmldonkey-0.10.1-1.pm.2.i586.rpm: Header V3 DSA signature: NOKEY, key ID 27db6f5b
    error: Failed dependencies:
    libexpat.so.0 is needed by kmldonkey-0.10.1-1.pm.2.i586

    Après vérification :

    noestrium:/usr/lib # ls -l libexpat*
    -rw-r--r-- 1 root root 157460 Apr 23 03:42 libexpat.a
    -rw-r--r-- 1 root root 793 Apr 23 03:42 libexpat.la
    lrwxrwxrwx 1 root root 17 May 18 19:30 libexpat.so -> libexpat.so.1.5.0
    lrwxrwxrwx 1 root root 17 May 25 01:21 libexpat.so.0 -> libexpat.so.1.5.0
    lrwxrwxrwx 1 root root 17 May 18 19:30 libexpat.so.1 -> libexpat.so.1.5.0
    -rwxr-xr-x 1 root root 126496 Apr 23 03:42 libexpat.so.1.5.0

    Après des recherches sur internet, il semblerait qu'il faille installer le paquet "compat-expat1-1.95.8-6"

    Si je fais une recherche dans Yast2, les paquets suivants sont installés :


    compat │2006.1.25 │2006.1.25 │Libraries from Compatibility Versions
    compat-curl2 │7.11.0 │7.11.0 │Curl Compatibility Library
    compat-libstdc++ │5.0.7 │5.0.7 │The Old stdc++ Library
    compat-openssl097g │0.9.7g │0.9.7g │Secure Sockets and Transport Layer Security
    compat-readline4 │4.3 │4.3 │The Old readline Library 4.3

    Est-ce une question de version de librairie?

    Merci.

  2. #2
    Grand caméléon arc-en-ciel
    Inscrit
    septembre 2004
    Lieu
    Lannoy, France
    Distribution
    openSUSE 13.2 (64 bits)
    Environnement
    KDE
    Messages
    14 119
    Donc tu as récuperé Kmldonkey ici : http://packman.links2linux.de/?action=451

    Vérifie que ce fichier est bien installé : expat
    Code:
    # rpm -qa | grep expat
    expat-1.95.8-5
    Ambassadeur et membre openSUSE - Région 59 Nord - France
    HP Probook 4350s sous openSUSE 13.2
    ==[GaLaGaNN's Blog]==


  3. #3
    Voilà le résultat de ma commande :
    Code:
    noestrium:~ # rpm -qa | grep expat
    expat-2.0.0-11
    compat-expat1-1.95.8-6
    En fait, j'ai forcé l'installation du paquet sous Yast en Ignorant la dépendance, et KMLdonkey fonctionne quand même.... faudrait voir dans le temps si c'est stable.

  4. #4
    Grand caméléon arc-en-ciel
    Inscrit
    septembre 2004
    Lieu
    Lannoy, France
    Distribution
    openSUSE 13.2 (64 bits)
    Environnement
    KDE
    Messages
    14 119
    [Réglé] ???
    Ambassadeur et membre openSUSE - Région 59 Nord - France
    HP Probook 4350s sous openSUSE 13.2
    ==[GaLaGaNN's Blog]==


  5. #5
    Oui, [Réglé]

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé